Installation Instructions

Home | FAQ | CUSIP Global Services Website | Bitbucket | Bamboo | Try it!

The following installation instructions detail what is required and how to install the Coherent Data Adapter: CUSIP Global Services Web Edition package.

Prerequisites

* R version 3.2.3 (2015-12-10) — download it here: Windows / Mac.
* Java version 1.8.0_66 (or above) — see here.

Installation Instructions

1.) Download the rCUSIPGlobalServices source package.
2.) install.packages (“RJSONIO”)
3.) install.packages (“rJava”)
4.) install.packages (“rGroovy”)
5.) Either

install.packages("C:/.../rCUSIPGlobalServices_0.85.tar.gz", repos=NULL, type="source",INSTALL_opts=c("--no-multiarch"))
or
install.packages("http://www.coherentlogic.com/wordpress/etc-www/downloads/rCUSIPGlobalServices_0.85.tar.gz", repos=NULL, type="source")

6.) Try one of the examples on the product homepage — for instance:

library(rCUSIPGlobalServices)
rCUSIPGlobalServices::Initialize ()
rCUSIPGlobalServices::Login (userId = "yourUserId", password = "yourPassword")
result <- rCUSIPGlobalServices::GetCurrencies ()
result

Send us an email if you run into problems and we’ll assist.

—–

1.) See below — 32-bit Java may be installed, when 64-bit is required.

Error : .onLoad failed in loadNamespace() for ‘rJava’, details:
call: inDL(x, as.logical(local), as.logical(now), …)
error: unable to load shared object ‘C:/Users/…/Documents/R/winlibrary/2.13/rJava/libs/x64/rJava.dll’:
LoadLibrary failure: %1 is not a valid Win32 application.

Error: package/namespace load failed for ‘rJava’